Avatar for user110566

user110566

Member since Mar 2020 • Last active Mar 2020
  • 1 conversations
  • 5 comments

Most recent activity

    • 14 comments
    • 206 views
  • in Mechanics & Fixin'
    Avatar for user110566

    It's slipping on both rings

  • in Mechanics & Fixin'
    Avatar for user110566

    The sound is coming from the cassette, that's why I'm assuming it's on that side. Let me take some pics from the crank quickly.

  • in Mechanics & Fixin'
    Avatar for user110566

    Yes. I've tried 2 chains and the same issue. It is a 10 speed chain. And yes it slips in all gears.

  • in Mechanics & Fixin'
    Avatar for user110566

    Now that you're saying, could be a problem. They do kinda look worn.

  • in Mechanics & Fixin'
    Avatar for user110566

    Hey guys. I had a 2x7 road bike and I decided to upgrade it since I use it every day. I bought new wheels and a complete second hand 2x10 tiagra groupset. The components were in good condition, the only thing was missing is the chain. So I put a new one on, but it wasn't seem to be working, it was slipping a lot. My colleague told me to change the cassette because its too worn. So I bought a brand new tiagra cassette that matches the groupset. So it's basically a brand new cassette and chain. Well, that didn't solve the problem. The chain is still slipping even though they are not used. The small ring on the front is a bit bent so I thought it must be that, but no because it's doing the same with the top ring as well. It's slipping even if I don't put pressure on the chain just using the bike normally. What could cause the problem?

Actions