Front derailleur not shifting help

Posted on
  • Hi, I have a shimano mountain LX fd mounted on a mercian tourer with a double stronglight chainset - 14t difference. The fd was working fine with a shimano friction shifter, I then changed from a flat bar setup to drops and to rsx brifters. Rear/right works fine shifting up and down 7 speed casette - rd is a shimano stx rc. But the front barely moves the derailleur by a mm or so - although the cable itself goes way slack. What's wrong? Has the fd magically jammed during the switch over? LBS said road shifters wouldn't work with mountain derailleur, but was advised by @Bikesandboats here that pull ratio of shimano 7 speed road and mtb is the same, so in theory this should work? I also know for a fact as I have the service history of the bike that it has previously run rsx brifters, although I can't say for certain with this specific front derailleur so maybe that is moot. Thanks in advance

  • Play the limit screws

  • Check your limit screws and the cable routing into the derailleur. Are you able to shift the chain by manually pulling the cable?

  • a lot of those old brifters have issues with sticky grease and non working ratchets, easy enough to sort if you know where to apply some vaseline oil and activate the clasp with a 'pokey thing'. Also ive seen people miss the hole the actual gear cable goes through and get the cable head jammed inbetween the rotating part and the body in such a way it seems as though its trying to shift. As silly as it sounds you need to check that. Theres a little grub nut that helps secure the blades axle pin to the body and this needs to be removed to be able to push the pin out. With the blade and hence mechanism removed you can set about getting under the plastic cap at the rear of the mechanism. Sometimes you can free the catch and release the ratchet if its stuck in a loaded position or if its stuck open and slips you can free it up to click properly- its a little bit like a manual winding watch except not as delicate. https://www.youtube.com/watch?v=xkGNN_2C­fCY

    actually watch this it help.

  • front barely moves the derailleur by a mm or so - although the cable itself goes way slack

    Moves which way?

    Default position for front derailer is on the inner ring, with a slack cable. You move it to the outer by tightening the cable.

    So, if you're saying it's slack and not moving are you suggesting you'd already shifted into the bigger ring? It sounds to me like you've not pulled enough cable through FD clamp so all you're doing is loosening and tightening the cable which isn't enough to move the cage.

    Maybe I missed something in the explanation though? tldr

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Front derailleur not shifting help

Posted by Avatar for krj @krj

Actions