Headset help!

Posted on
  • So I'm building up a Peugeot conversion for my younger brother and I bought a cheap Stronglight headset from the Bay just to throw on as I gradually build up and source the rest of his parts.
    I unboxed it and proceeded to try and put it on the forks but it just didn't go on further that a few mm. I then realised why.

    I'm pretty sure the thread on the headset shouldn't be like this...


    2 Attachments

    • 13234822_10209514964980717_331243315_o.jpg
    • 13275236_10209514965420728_1701155683_o.jpg
  • I'm not sure what I'm seeing, but that looks nuts. The top photo looks like way too many thread starts. The bottom one looks like the thread is left handed. Probably the thread has been rolled, wrongly. I vote for manufacturing defect.

  • Sorry I should have explained better. So this is the upper race and it's just got both types of thread, left and right...
    The locknut has the exact same thread on it. I assumed it was manufacturing defect but I couldn't quite believe they could get it this wrong.

  • it's just got both types of thread, left and right...

    Crazeee! Send it back.

  • That does look mental and I can't quite get my head round it. Also, make sure you have the right size! Those old peugeot's can sometimes have different sized steerers too http://www.sheldonbrown.com/velos.html

  • The size is okay (luckily), because I've got my old headset cups on it with the locknut just to keep it all together. But yeah, I bought it off eBay a few month ago and have only just go round to trying to install it, sent the guy a message and hope to hear back from him soon.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Headset help!

Posted by Avatar for Tom_Illsley @Tom_Illsley

Actions